VIDA Verify Service - Authoritative Source Incident

Incident Report for VIDA System Status

Resolved

Service is good and stable. This incident has been resolved.
Posted Mar 24, 2025 - 11:22 WIB

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2025 - 11:09 WIB

Identified

VIDA is experiencing degraded performance for some service requests on VIDA Verify Services due to an issue with our Authoritative Partner's services. The VIDA technical team has investigated the issue and identified that the root cause appears to be with our Authoritative Partner. We are actively collaborating with their team to restore service.
Posted Mar 24, 2025 - 10:24 WIB
This incident affected: Authoritative source (Biometric Verification - Authoritative Sources).