VIDA Verify Service Degradation - Authoritative

Incident Report for VIDA System Status

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 12:40 WIB

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2025 - 11:52 WIB

Update

We hope this message finds you well. We are writing to inform you of a potential impact to some of our services. On Monday, 3rd February 2025, we encountered some intermittent issues with our Biometric Verification.

The details of the issue are as follows:
Date: February, 3rd 2025.
Problem: VIDA Biometric Verification services are performing with delay response for some of the transactions.
Impact: VIDA Face Biometric Service
Root Cause: VIDA experienced degraded service from our Authoritative Partner Service.
Remediation: Investigating.

We would like to express our sincerest apologies for any inconvenience this may have caused. Your business is important to us, and we are committed to restoring our services to full functionality as soon as possible.

For updates on the situation, please visit our FAQ page at www.vida.id/faq or contact us at support@vida.id for further assistance.

Thank you for your understanding and patience.


Sincerely,
PT. Indonesia Digital Identity (VIDA) Customer Support Team
Posted Feb 03, 2025 - 11:22 WIB

Identified

VIDA is experiencing degraded for Verification and Biometric on VIDA Verify Services from our Authoritative Partner's Services. VIDA technical team is investigated the issue and identified that seems to be an issue with our authoritative partner's services. VIDA technical team is working with VIDA's authoritative partner team towards service recovery.
Posted Feb 03, 2025 - 11:10 WIB
This incident affected: VIDA Verify (Identity Verification Services - VIDA) and Authoritative source (Biometric Verification - Authoritative Sources, Identity Verification - Authoritative Sources).