VIDA authority partner team has implemented the new fixing and services are coming back to normal now. We are monitoring the results.
Posted Aug 25, 2026 - 19:10 WIB
Update
Based on the latest investigation, the issue has been identified as a connectivity problem within the network provider.
The relevant network provider is currently troubleshooting the issue to restore connectivity. The VIDA team continues to monitor the situation and coordinate closely with the network provider to ensure that service recovery can be completed as soon as possible.
Posted Aug 25, 2026 - 18:20 WIB
Update
We regret to inform you that VIDA Verify services are still experiencing disruptions. Our technical team is working diligently with our Authoritative Partner’s team to resolve the issue and restore full functionality.
Posted Aug 25, 2026 - 16:57 WIB
Identified
VIDA is experiencing degraded performance for some service requests on VIDA Verify Services due to an issue with our Authoritative Partner's services. The VIDA technical team has investigated the issue and identified that the root cause appears to be with our Authoritative Partner. We are actively collaborating with their team to restore service.
Posted Aug 25, 2026 - 14:01 WIB
This incident affected: Authoritative source (Network Provider Service).