VIDA Sign Web Platform Service Degradation

Incident Report for VIDA System Status

Resolved

Service is stable and this incident has been resolved.
Posted Mar 06, 2026 - 11:38 WIB

Monitoring

A fix has been implemented by the technical team, and we are currently monitoring the results.
Posted Mar 06, 2026 - 11:37 WIB

Identified

We have noticed an issue where some users are unable to perform digital signing on the VIDA Sign Web. Our team is currently investigating this matter.

As a temporary workaround, we recommend performing the Digital Sign process through the VIDA Sign mobile application.

We apologize for the inconvenience caused.
Posted Mar 06, 2026 - 10:26 WIB
This incident affected: VIDA Sign (VSP Service).