VIDA Sign Service Incident - Intermittent

Incident Report for VIDA System Status

Resolved

Service is good and stable. This incident has been resolved.
Posted Mar 21, 2025 - 10:45 WIB

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 10:45 WIB

Identified

Some VIDA customers may experience intermittent performance degradation on certain VIDA Sign services. Our technical team is working to resolve the issue as quickly as possible.
Posted Mar 21, 2025 - 07:21 WIB
This incident affected: VIDA Sign (Digital Sign - Web, Cloud Signing (CSC), Digital Sign - API).