VIDA Verify Service Degradation

Incident Report for VIDA System Status

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 13:21 WIB

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 12:00 WIB

Update

We are continuing to work on a fix for this issue.
Posted Feb 27, 2026 - 10:28 WIB

Identified

We are notifying you of a potential impact to some of our services.

The details of the issue are as follows:
Date: February 27, 2026.
Issue: The Verify service is experiencing a decrease in service quality.
Impact: The Verify service is experiencing delayed responses.
Root Cause: Network issues with our Internet Service Provider.
Resolution: Under investigation.

Thank you for your understanding and patience.
Posted Feb 27, 2026 - 08:28 WIB
This incident affected: VIDA Verify (Identity Verification Services - VIDA, KTP OCR API, Liveness API, Biometric Verification service - VIDA, VIDA WEB eKYC Services, Liveness SDK).