VIDA WEB eKYC Service - Service Interruption

Incident Report for VIDA System Status

Resolved

This incident has been resolved.
Posted Aug 03, 2025 - 17:23 WIB

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2025 - 17:10 WIB

Identified

We hope this message finds you well. We are writing to inform you of a potential impact to some of our services. On Sunday, 03 August 2025, we encountered some issues with our Verify services.


The details of the issue are as follows:

Date : 03 August 2025
Problem : Web KYC Services Performance Degradation.
Impact : Web KYC Only.
Root Cause : Investigating.
Remediation : Investigating.
Posted Aug 03, 2025 - 16:36 WIB
This incident affected: VIDA Verify (VIDA WEB eKYC Services).