VIDA Verify Service FR&Demog Interruption

Incident Report for VIDA System Status

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 19:07 WIB

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2025 - 18:17 WIB

Identified

We are writing to inform you that our service experienced a temporary disruption between 17:56 and 18:17.
We would like to express our sincerest apologies for any inconvenience this may have caused.
Posted Jul 15, 2025 - 17:56 WIB
This incident affected: VIDA Verify (Identity Verification Services - VIDA, Biometric Verification service - VIDA, VIDA WEB eKYC Services).